NOIP信息学1060:均值--信息学一本通(c++)

时间限制: 1000 ms 内存限制: 65536 KB
提交数: 22316 通过数: 13390
【题目描述】
给出一组样本数据,包含n个浮点数,计算其均值,精确到小数点后4位。

【输入】
输入有两行,第一行包含一个整数n(n小于100),代表样本容量;第二行包含n个绝对值不超过1000的浮点数,代表各个样本数据。

【输出】
输出一行,包含一个浮点数,表示均值,精确到小数点后4位。

【输入样例】
2
1.0 3.0
【输出样例】
2.0000
【来源】

No

代码如下:
#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;
int main()
{
    int n, i;
    double data, avg, sum=0;
    cin >> n;
    for (i=0; i<n; i++){
        cin >> data;
        sum += data;
    }
    avg = sum/n;
    cout << fixed << setprecision(4) << avg << endl;
    return 0;
}

  

上一篇:HLS协议详解


下一篇:PAT (1060)爱丁顿数 25分