月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。
输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。
输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50
题目中的坑已经用红色标出,审题是关键
另外,double精度比float高
本题思路是求出每吨多少钱,然后每次选出最大的(性价比最高的)
进行运算,还需要考虑极端情况,也就是全部月饼都不够需求
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include <vector>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>
#define max 1000
#define debug 0
using namespace std;
int main() {
#if debug
freopen("in.txt", "r", stdin);
#endif
int n = 0,D=0;
double s = 0,d=0;
double store[max];
double sale[max];
memset(store, 0, sizeof(double)*max);
memset(sale, 0, sizeof(double)*max);
cin >> n>>D;
for (int i = 0; i < n; i++)
{
cin >> store[i];
}
for (int i = 0; i < n; i++)
{
cin >> sale[i];
}
double total = 0;
for (int i = 0; i < n; i++)
{
total += store[i];
}
if (total <= D)
{
double s = 0;
for (int i = 0; i < n; i++)
{
s += sale[i];
}
printf("%.2f", s);
return 0;
}
double saleperstore[max];
memset(saleperstore, 0, sizeof(double)*max);
for (int i = 0; i < n; i++)
{
saleperstore[i] = sale[i] / store[i];
}
int ma = 0;
while (d<D)
{
for (int i = 1; i < n; i++)
{
if (saleperstore[i] > saleperstore[ma])
ma = i;
}
if (store[ma] <= D-d)
{
d = d + store[ma];
s += sale[ma];
}else
{
s += saleperstore[ma] * (D-d);
d = D;
}
saleperstore[ma] = 0;
ma = 0;
}
printf("%.2f", s);
#if debug
freopen("CON", "r", stdin);
#endif
return 0;
}