pat甲级1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10
5
) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:
For each test case you should output the median of the two given sequences in a line.

Sample Input:
4 11 12 13 14
5 9 10 15 16 17
Sample Output:
13

感觉写的没问题但是在测试点六报错了 只有23分

#include<iostream>
using namespace std;
int a[200001],b[400002];
int main(){
    int x,y;
    cin>>x;
    for(int i = 1;i<=x;i++)
        cin>>a[i];
    cin>>y;
    int index = 1,flag = 0,z; //index纪录b数组,flag用来判断是否需要读入z;
    for(int i = 1;i<=y+x;i++){
        if(flag == 0){
            cin>>z;
        }
        if(z<=a[index] || a[index] == 0){
            b[i] = z;
            flag = 0;
        }
        else if(z>a[index]&&a[index]!=0){
            b[i] = a[index];
            flag = 1;
            index++;
        }
    }
    int median = (x+y+1)/2;
        cout<<b[median];
}
上一篇:不同电子设备之间传输文件的方案


下一篇:PAT乙级 1099 性感素数