1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
6
≤a,b≤10
6
. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
结尾无空行
Sample Output:
-999,991
#include<cstdio>
int main()
{
int a,b,sum;
scanf("%d%d",&a,&b);
sum=a+b;
int out[7];
if(sum<0)
{
printf("-");
sum=-sum;
}
int len=0;
do{
out[len++]=sum%10;
sum=sum/10;
}while(sum!=0);
for(int i=len-1;i>=0;i--)
{
printf("%d",out[i]);
if(i%3==0&&i>0)
printf(",");
}
return 0;
}