PAT-A1029 Median

A1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17结尾无空行

Sample Output:

13
结尾无空行

分析:

  • 数组越界

  • 中间位置

  • 双指针

代码:

#include<cstdio>
const int maxn=1000010;
const int INF=0x7fffffff;//int的最大值 
int main(){
	int m,n;
	int a[maxn],b[maxn];
	scanf("%d",&m);
	for(int i=0;i<m;i++){
		scanf("%d",&a[i]);
	}
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&b[i]);
	}
	a[m]=b[n]=INF;//解决数组越界 
	int i=0,j=0,count=0;//注意这里=0 
	int mid=(m+n-1)/2;//中间位置 
	while(count<mid){
		if(a[i]<b[j]) i++;
		else j++;
		count++;
	}
	if(a[i]<b[j]) printf("%d",a[i]);
	else printf("%d",b[j]); 
	return 0;
} 
上一篇:jQery基础学习(JavaScript学习)


下一篇:PAT甲级1049 Counting Ones (30 分)--参考于柳神