Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming. Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file. Each case consists of two hexadecimal integers A and B in a line seperated by a blank. The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90
2C
11
-2C
-90
#include <cstdio>
int main()
{
__int64 a,b,c;
//十六进制数直接可以运算,字母X要大写
while(~scanf("%I64X%I64X",&a,&b))
{
//输入的时候是10...10101010
//存储的时候是11...01010110补码形式
//输出的时候是FF...56
//如果和的符号位是-的话,先-1再取反就变回原码形式
//然后再另外输出一个'-'
c=a+b;
if(c<)
printf("-%I64X\n",~(c-));
else
printf("%I64X\n",c);
}
return ;
}