HDU 5280 Senior's Array

Senior's Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 528    Accepted Submission(s): 209

Problem Description
One day, Xuejiejie gets an array
AHDU 5280 Senior's Array.
Among all non-empty intervals of AHDU 5280 Senior's Array,
she wants to find the most beautiful one. She defines the beauty as the sum of the interval. The beauty of the interval---[L,R]HDU 5280 Senior's Array
is calculated by this formula : beauty(L,R) = A[L]+A[L+1]+……+A[R]HDU 5280 Senior's Array.
The most beautiful interval is the one with maximum beauty.



But as is known to all, Xuejiejie is used to pursuing perfection. She wants to get a more beautiful interval. So she asks Mini-Sun for help. Mini-Sun is a magician, but he is busy reviewing calculus. So he tells Xuejiejie that he can just help her change one
value of the element of AHDU 5280 Senior's Array
to PHDU 5280 Senior's Array
. Xuejiejie plans to come to see him in tomorrow morning.



Unluckily, Xuejiejie oversleeps. Now up to you to help her make the decision which one should be changed(You must change one element).
 
Input
In the first line there is an integer
THDU 5280 Senior's Array,
indicates the number of test cases.



In each case, the first line contains two integers
nHDU 5280 Senior's Array
and PHDU 5280 Senior's Array.
nHDU 5280 Senior's Array
means the number of elements of the array. PHDU 5280 Senior's Array
means the value Mini-Sun can change to.



The next line contains the original array.



1≤n≤1000HDU 5280 Senior's Array,
−10HDU 5280 Senior's Array9HDU 5280 Senior's Array≤A[i],P≤10HDU 5280 Senior's Array9HDU 5280 Senior's ArrayHDU 5280 Senior's Array
 
Output
For each test case, output one integer which means the most beautiful interval's beauty after your change.
 
Sample Input
2
3 5
1 -1 2
3 -2
1 -1 2
 
Sample Output
8
2
 
Source
题意: 给一个数组a[n],问使数组中某一个值变成P。得到a[l]+a[l+1]+......+a[r]最大是多少。
#include<stdio.h>
const int N = 1005;
const int inf = 1<<29;
int main(){
__int64 dp[N],P,a[N],ans;
int n,T;
scanf("%d",&T);
while(T--){
scanf("%d%I64d",&n,&P);
for(int i=1; i<=n; i++)
scanf("%I64d",&a[i]); ans=-inf;
dp[0]=0; for(int i=1; i<=n; i++)
{
int tmp=a[i];
a[i]=P;
for(int j=1; j<=n; j++)
{
if(dp[j-1]>0)
dp[j]=dp[j-1]+a[j];
else
dp[j]=a[j];
if(dp[j]>ans)
ans=dp[j];
}
a[i]=tmp;
}
printf("%I64d\n",ans);
}
}

上一篇:HDU 5280 Senior's Array (暴力,水)


下一篇:编写高质量代码改善C#程序的157个建议——建议156:利用特性为应用程序提供多个版本