UVA 796 Critical Links

tarjan求桥

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

UVA 796 Critical Links


  Critical Links 

In a computer network a link L, which interconnects two servers, is considered critical if there are at least two servers A and B such that all network interconnection paths between A and B pass through L. Removing a critical link generates two disjoint sub-networks such that any two servers of a sub-network are interconnected. For example, the network shown in figure 1 has three critical links that are marked bold: 0 -13 - 4 and 6 - 7.

UVA 796 Critical Links

Figure 1: Critical links

It is known that:

1.
the connection links are bi-directional;
2.
a server is not directly connected to itself;
3.
two servers are interconnected if they are directly connected or if they are interconnected with the same server;
4.
the network can have stand-alone sub-networks.


Write a program that finds all critical links of a given computer network.

Input 

The program reads sets of data from a text file. Each data set specifies the structure of a network and has the format:


UVA 796 Critical Links

UVA 796 Critical Links

...

UVA 796 Critical Links


The first line contains a positive integer UVA 796 Critical Links(possibly 0) which is the number of network servers. The next UVA 796 Critical Links lines, one for each server in the network, are randomly ordered and show the way servers are connected. The line corresponding to serverkUVA 796 Critical Links, specifies the number of direct connections of serverk and the servers which are directly connected to serverk. Servers are represented by integers from 0 to UVA 796 Critical Links. Input data are correct. The first data set from sample input below corresponds to the network in figure 1, while the second data set specifies an empty network.

Output 

The result of the program is on standard output. For each data set the program prints the number of critical links and the critical links, one link per line, starting from the beginning of the line, as shown in the sample output below. The links are listed in ascending order according to their first element. The output for the data set is followed by an empty line.

Sample Input 

8
0 (1) 1
1 (3) 2 0 3
2 (2) 1 3
3 (3) 1 2 4
4 (1) 3
7 (1) 6
6 (1) 7
5 (0)

0

Sample Output 

3 critical links
0 - 1
3 - 4
6 - 7

0 critical links



Miguel Revilla
2001-01-05

[]   [Go Back]   [Status]  


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
#include <vector>

using namespace std;

const int maxV=10010,maxE=100010;

struct Edge
{
    int to,next;
    bool cut;
}edge[maxE];

int Adj[maxV],Size;

void init()
{
    Size=0;
    memset(Adj,-1,sizeof(Adj));
}

void Add_Edge(int u,int v)
{
    edge[Size].to=v;
    edge[Size].next=Adj[u];
    edge[Size].cut=false;
    Adj[u]=Size++;
}

int Low[maxV],DFN[maxV],Stack[maxV];
int Index,top,bridge;
bool Instack[maxV],cut[maxV];
int add_block[maxV];

void Tarjan(int u,int pre)
{
    int v;
    Low[u]=DFN[u]=++Index;
    Stack[top++]=u;
    Instack[u]=true;
    int son=0;
    for(int i=Adj[u];~i;i=edge[i].next)
    {
        v=edge[i].to;
        if(v==pre) continue;
        if(!DFN[v])
        {
            son++;
            Tarjan(v,u);
            Low[u]=min(Low[u],Low[v]);

            if(Low[v]>DFN[u])//bridge
            {
                bridge++;
                edge[i].cut=edge[i^1].cut=true;
            }

            if(u!=pre&&Low[v]>=DFN[u])//cut_point
            {
                cut[u]=true;
                add_block[u]++;
            }
        }
        else
        {
            Low[u]=min(Low[u],DFN[v]);
        }
    }

    if(u==pre&&son>1) cut[u]=true;
    if(u==pre) add_block[u]=son-1;

    Instack[u]=false; top--;
}

int n;

void solve(int n)
{
    memset(DFN,0,sizeof(DFN));
    memset(Instack,false,sizeof(Instack));
    memset(add_block,0,sizeof(add_block));
    memset(cut,false,sizeof(cut));

    Index=top=bridge=0;

    for(int i=1;i<=n;i++)
    {
        if(!DFN[i]) Tarjan(i,i);
    }

    printf("%d critical links\n",bridge);
    if(bridge==0)
    {
        putchar(10);
        return ;
    }

    vector< pair<int,int> > vs;

    for(int i=1;i<=n;i++)
    {
        int u=i,v;
        for(int j=Adj[i];~j;j=edge[j].next)
        {
            v=edge[j].to;
            if(v<=u) continue;
            if(edge[j].cut)
                vs.push_back(make_pair(u,v));
        }
    }

    sort(vs.begin(),vs.end());

    for(int i=0;i<vs.size();i++)
        printf("%d - %d\n",vs[i].first-1,vs[i].second-1);

    putchar(10);
}

int main()
{
while(scanf("%d",&n)!=EOF)
{
    int u,t,v;
    init();
    set< pair<int,int> > spII;
for(int i=0;i<n;i++)
{
    scanf("%d (%d)",&u,&t);
    u++;
    while(t--)
    {
        scanf("%d",&v);
        v++;
        if(v<=u) continue;
        Add_Edge(u,v);
        Add_Edge(v,u);
    }
}
    solve(n);
}
    return 0;
}



UVA 796 Critical Links

上一篇:面向对象技术


下一篇:LA 3905 Meteor / 区间扫描