1126 数字统计
2010年NOIP全国联赛普及组
时间限制: 1 s
空间限制: 128000 KB
题目等级 : 白银 Silver
题目描述 Description
请统计某个给定范围[L, R]的所有整数中,数字2出现的次数。
比如给定范围[2, 22],数字2在数2中出现了1次,在数12中出现1次,在数20中出现1次,在数21中出现1次,在数22中出现2次,所以数字2在该范围内一共出现了6次。
数据范围 1 ≤ L ≤ R≤ 10000。
输入描述 Input Description
输入共1 行,为两个正整数L 和R,之间用一个空格隔开。
输出描述 Output Description
输出共1 行,表示数字2 出现的次数。
样例输入 Sample Input
2 22
样例输出 Sample Output
6
数据范围及提示 Data Size & Hint
分类标签 Tags 点此展开
#include<iostream>
#include<cstdio>
using namespace std;
int tot=;
int main()
{
int l,r;
scanf("%d%d",&l,&r);
for(int i=l;i<=r;i++)
{
int p=i;
while(p!=)
{
if(p%==)
tot++;
p=p/;
}
}
printf("%d",tot);
return ;
}