题目链接: 传送门
Kefa and Company
time limit per test:2 second memory limit per test:256 megabytes
Description
Kefa wants to celebrate his first big salary by going to restaurant. However, he needs company.
Kefa has n friends, each friend will agree to go to the restaurant if Kefa asks. Each friend is characterized by the amount of money he has and the friendship factor in respect to Kefa. The parrot doesn't want any friend to feel poor compared to somebody else in the company (Kefa doesn't count). A friend feels poor if in the company there is someone who has at least d units of money more than he does. Also, Kefa wants the total friendship factor of the members of the company to be maximum. Help him invite an optimal company!
Input
The first line of the input contains two space-separated integers, n and d (1 ≤ n ≤ 105, ) — the number of Kefa's friends and the minimum difference between the amount of money in order to feel poor, respectively.
Next n lines contain the descriptions of Kefa's friends, the (i + 1)-th line contains the description of the i-th friend of type mi, si (0 ≤ mi, si ≤ 109) — the amount of money and the friendship factor, respectively.
Output
Print the maximum total friendship factir that can be reached.
Sample Input
4 5
75 5
0 100
150 20
75 1
5 100
0 7
11 32
99 10
46 8
87 54
Sample Output
100
111
解体思路:
今天想起很多题目很补,开始补题,当时这道题搞了很久,一直超时,不懂把factor值存起来= =果然多天的训练,有一定的效果
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef __int64 LL;
struct node{
LL money,fac;
};
node p[100005];
LL sum[100005];
bool cmp(node x,node y)
{
if (x.money == y.money)
return x.fac > y.fac;
else
return x.money < y.money;
}
int main()
{
int n,d;
while (~scanf("%d%d",&n,&d))
{
LL res = 0;
memset(p,0,sizeof(p));
memset(sum,0,sizeof(sum));
for (int i = 0;i < n;i++)
{
scanf("%I64d%I64d",&p[i].money,&p[i].fac);
}
sort(p,p+n,cmp);
for (int i = 0;i < n;i++)
{
sum[i+1] = sum[i] + p[i].fac;
}
int i= 0,j = 1;
while (i < n)
{
while (j < n && p[j].money -p[i].money < d)
{
j++;
}
res = max(res,sum[j] - sum[i]);
i++;
}
printf("%I64d\n",res);
}
return 0;
}