hdu2509Be the Winner (尼姆博弈,注意全为1的情况)

Problem Description
Let‘s consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

Sample Input
2 2 2 1 3

Sample Output
No Yes
#include<stdio.h>
int main()
{
int n,a,c,t;
while(scanf("%d",&n)==1)
{
  c=0;t=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a); c^=a; if(a>1) t=1;
}
printf("%s\n",(c!=0&&t||c==0&&t==0)?"Yes":"No");
}
}



hdu2509Be the Winner (尼姆博弈,注意全为1的情况)

上一篇:Vmware 导入虚拟机ovf报错之“未通过ovf规范一致性或虚拟硬件合规性检查”的解决方法


下一篇:Revit API选择三维视图上一点