HDOJ2006求奇数的乘积

求奇数的乘积

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43666    Accepted Submission(s): 28236

Problem Description
给你n个整数,求他们中所有奇数的乘积。
 
Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。
 
Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。
 
Sample Input
3 1 2 3
4 2 3 4 5
 
Sample Output
3
15
 
Author
lcy
 
#include<stdio.h>

int main()
{
int n, x, s;
while(scanf("%d", &n) == )
{
s = ;//每次初始化s
while(n--)
{
scanf("%d", &x);
if(x % != )
s *= x;
}
printf("%d\n", s);
}
return ;
}
上一篇:Left Join 与Right Join 与 Inner Join 与 Full Join的区别


下一篇:基于Debian的Kali设置外网IP