OpenJudge4980:拯救行动//stl优先队列

总时间限制: 
10000ms
内存限制: 
65536kB
描述

公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。 
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。 
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。

给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入
第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入 
1、两个整数代表N和M, (N, M <= 200). 
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#"代表墙壁。
输出
如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible"
样例输入
2
7 8
#@#####@
#@a#@@r@
#@@#x@@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@
13 40
@x@@##x@#x@x#xxxx##@#x@x@@#x#@#x#@@x@#@x
xx###x@x#@@##xx@@@#@x@@#x@xxx@@#x@#x@@x@
#@x#@x#x#@@##@@x#@xx#xxx@@x##@@@#@x@@x@x
@##x@@@x#xx#@@#xxxx#@@x@x@#@x@@@x@#@#x@#
@#xxxxx##@@x##x@xxx@@#x@x####@@@x#x##@#@
#xxx#@#x##xxxx@@#xx@@@x@xxx#@#xxx@x#####
#x@xxxx#@x@@@@##@x#xx#xxx@#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#xx@##@#@##xx@#@@x@x
x#x#@x@#x#@##@xrx@x#xxxx@##x##xx#@#x@xx@
#x@@#@###x##x@x#@@#@@x@x@@xx@@@@##@@x@@x
x#xx@x###@xxx#@#x#@@###@#@##@x#@x@#@@#@@
#@#x@x#x#x###@x@@xxx####x@x##@x####xx#@x
#x#@x#x######@@#x@#xxxx#xx@@@#xx#x#####@
样例输出
13
7

分析:

这道题就是一道水题。看起来好像有一些动态规划。但是!这怎么可能DP。所以。考虑BFS。BFS要保证最少步数的优先,这样最先走到目标一定是最优接。

放出代码:

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
struct node{
int x,y,step;
friend bool operator < (node a,node b){
return a.step>b.step;
}
};
priority_queue<node>qu;
char map_1[210][210];
int visit[210][210];
int left[4]={0,0,1,-1},right[4]={1,-1,0,0};
int starx,stary,lastx,lasty;
void BFS()
{
node start;
start.step=0;
start.x=starx;start.y=stary;
visit[starx][stary]=1;
qu.push(start);
while(!qu.empty()){
node first=qu.top();
qu.pop();
if(first.x==lastx&&first.y==lasty){
printf("%d\n",first.step);
return ;
}
for(int i=0;i<4;++i)
{
if(map_1[first.x+left[i]][first.y+right[i]]=='#')continue;
if(visit[first.x+left[i]][first.y+right[i]])continue;
if(map_1[first.x+left[i]][first.y+right[i]]=='x'){
node news;
news.x=first.x+left[i];
news.y=first.y+right[i];
news.step=first.step+2;
qu.push(news);
visit[news.x][news.y]=1;
}
else {
node news;
news.x=first.x+left[i];
news.y=first.y+right[i];
news.step=first.step+1;
qu.push(news);
visit[news.x][news.y]=1;
}
}
}
printf("Impossible\n");
return ;
}
int main()
{
//freopen("4980.in","r",stdin);
//freopen("4980.out","w",stdout);
int T;
scanf("%d",&T);
while(T--){
memset(map_1,'#',sizeof(map_1));
int x,y;
scanf("%d%d\n",&x,&y);
for(int i=1;i<=x;++i)
{
for(int j=1;j<=y;++j)
{
scanf("%c",&map_1[i][j]);
if(map_1[i][j]=='a'){
lastx=i;
lasty=j;
}
if(map_1[i][j]=='r'){
starx=i;
stary=j;
}
}
scanf("\n");
}
memset(visit,0,sizeof(visit));
while(!qu.empty())qu.pop();
BFS();
}
//fclose(stdin);
//fclose(stdout);
return 0;
}
上一篇:类的简介 | Python从入门到精通:高阶篇之二十


下一篇:《Linux设备驱动开发详解 A》一一第3章Linux内核及内核编程