Photoshoot

Photoshoot

题目描述
Farmer John is lining up his N cows (2≤N≤103), numbered 1…N, for a photoshoot. FJ initially planned for the i-th cow from the left to be the cow numbered ai, and wrote down the permutation a1,a2,…,aN on a sheet of paper. Unfortunately, that paper was recently stolen by Farmer Nhoj!
Luckily, it might still possible for FJ to recover the permutation that he originally wrote down. Before the sheet was stolen, Bessie recorded the sequence b1,b2,…,bN−1 that satisfies bi=ai+ai+1 for each 1≤i<N.
based on Bessie’s information, help FJ restore the “lexicographically minimum” permutation a that could have produced b. A permutation x is lexicographically smaller than a permutation y if for some j, xi=yi for all i<j and xj<yj (in other words, the two permutations are identical up to a certain point, at which x is smaller than y). It is guaranteed that at least one such a exists.
输入
The first line of input contains a single integer N.
The second line contains N−1 space-separated integers b1,b2,…,bN−1.
输出
A single line with N space-separated integers a1,a2,…,aN.
样例输入

5
4 6 7 6

样例输出

3 1 5 2 4

提示
a produces b because 3+1=4, 1+5=6, 5+2=7, and 2+4=6.

解题思路
暴力枚举第一位数

AC代码

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int a[maxn];
int b[maxn];
int vis[maxn];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=2;i<=n;++i)
    {
        scanf("%d",&b[i]);
    }
    for(int i=1;i<=n;++i)
    {
        a[1]=i;
        int f=0;
        for(int j=2;j<=n;++j)
        {
            int temp=b[j]-a[j-1];
            if(temp<=n&&temp>=1&&vis[temp]!=i)
            {
                a[j]=temp;
                vis[temp]=i;
            }
            else
            {
                f=1;
                break;
            }
        }
        if(f) continue;
        else break;
    }
    for(int i=1;i<=n;++i) printf("%d%c",a[i],i==n?'\n':' ');
    return 0;
}

PhotoshootPhotoshoot umbrellalla 发布了6 篇原创文章 · 获赞 0 · 访问量 233 私信 关注
上一篇:567. Permutation in String


下一篇:LeetCode - Next Permutation