1067 Sort with Swap(0, i) (25 分)
Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *)
is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:
Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.
Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9
贪心和哈希的结合。题意是用0与序列中的数交换,使数列有序。每次让0与0所在位置的数交换。若0回到本位,还未完全有序,则让0与一个不在本位的数交换,然后重复此过程。
参考代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
int pos[100010];
int main()
{
int n,ans=0;
while(scanf("%d",&n)!=EOF)
{
int left=n-1,num; //LEFT存放除0以外不在本位上的数的个数
for(int i=0;i<n;++i)
{
scanf("%d",&num);
pos[num]=i;//num所处的位置为i
if(num==i&&num!=0)
left--;
}
int k=1;//k存放除0以外当前不在本位上的最小的数
while(left>0)
{
if(pos[0]==0)//如果0在本位,则寻找一个当前不在本位上的数与之交换
{
while(k<n)
{
if(pos[k]!=k)
{
swap(pos[0],pos[k]);
ans++;
break;
}
k++;//判断k+1是否在本位
}
}
while(pos[0]!=0)//只要0不在本位,就将0所在位置的数的当前所处位置与0的位置交换
{
swap(pos[0],pos[pos[0]]);
ans++;
left--;
}
}
printf("%d\n",ans);
}
return 0;
}