HDOJ 1269 迷宫城堡

tarjan。。。。。

迷宫城堡

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5854    Accepted Submission(s): 2572


Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
 

Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
 

Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
 

Sample Input
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
 

Sample Output
Yes No
 

Author
Gardon
 

Source
 

Recommend
lxj   |   We have carefully selected several similar problems for you:  1142 1217 1162 1068 1116 
 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAXE=110000,MAXV=11000;

struct Edge
{
    int to,next;
}edge[MAXE];

int Adj[MAXV],Size;

int Low[MAXV],DFN[MAXV],Stack[MAXV],Belong[MAXV];
int Index,top,scc,n,m;
bool Instack[MAXV];

void Add_Edge(int u,int v)
{
    edge[Size].to=v;
    edge[Size].next=Adj[u];
    Adj[u]=Size++;
}

void init()
{
    memset(Adj,-1,sizeof(Adj));
    Size=0;
}

void Tarjan(int u)
{
    int v;
    Low[u]=DFN[u]=++Index;
    Stack[top++]=u;
    Instack[u]=true;

    for(int i=Adj[u];~i;i=edge[i].next)
    {
        v=edge[i].to;
        if(!DFN[v])
        {
            Tarjan(v);
            Low[u]=min(Low[u],Low[v]);
        }
        else Low[u]=min(Low[u],DFN[v]);
    }

    if(Low[u]==DFN[u])
    {
        scc++;
        do
        {
            v=Stack[--top];
            Instack[v]==false;
            Belong[v]=scc;
        }while(v!=u);
    }
}

int solve(int n)
{
    memset(DFN,0,sizeof(DFN));
    memset(Instack,false,sizeof(Instack));

    Index=scc=top=0;

    for(int i=1;i<=n;i++)
    {
        if(!DFN[i]) Tarjan(i);
    }

    return scc;
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
    if(n==0&&m==0) break;

    init();
    for(int i=0;i<m;i++)
    {
        int xx,yy;
        scanf("%d%d",&xx,&yy);
        Add_Edge(xx,yy);
    }

    if(solve(n)==1)
        puts("Yes");
    else
        puts("No");
}
    return 0;
}






HDOJ 1269 迷宫城堡

上一篇:querySelectorAll 在部分微信版本里面foreach出现的问题


下一篇:深入分析UI 上层事件处理核心机制 Choreographer