Problem Description:
Given a stack which can keep M M M numbers at most. Push N N N numbers in the order of 1 , 2 , 3 , … , N 1, 2, 3, \ldots, N 1,2,3,…,N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M M M is 5 and N N N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M M M (the maximum capacity of the stack), N N N (the length of push sequence), and K K K (the number of pop sequences to be checked). Then K K K lines follow, each contains a pop sequence of N N N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
Problem Analysis:
本题是一个栈模拟题,给定 k k k 组弹出序列,对于每一组弹出序列,我们模拟栈压入弹出的过程进行判断即可。时间复杂度为 O ( n 2 ) O(n^2) O(n2)
Code
#include <iostream>
#include <algorithm>
#include <stack>
using namespace std;
const int N = 1010;
int n, m, k;
int a[N];
bool check()
{
stack<int> stk;
for (int i = 1, j = 0; i <= n; i ++ )
{
stk.push(i);
if (stk.size() > m) return false;
while (stk.size() && stk.top() == a[j])
{
stk.pop();
j ++ ;
}
}
return stk.empty();
}
int main()
{
cin >> m >> n >> k;
while (k -- )
{
for (int i = 0; i < n; i ++ ) scanf("%d", &a[i]);
if (check()) puts("YES");
else puts("NO");
}
return 0;
}