面向对象程序设计上机练习三(有默认参数的函数)

面向对象程序设计上机练习三(有默认参数的函数)

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

利用默认参数的函数实现求2个或3个整数的最大值。

Input

输入3个int型整数。

Output

输出第1、2个整数及其最大值;
输出第1、2、3个整数及其最大值。

Example Input

88 66 99

Example Output

88 66 88
88 66 99 99

Code realization

#include <iostream>

using namespace std;
int max(int a,int b)
{
    if(a>=b)
        return a;
    else
        return b;
}
int main()
{
    int a,b,c;
    cin>>a>>b>>c;
    cout<<a<<" "<<b<<" "<<max(a,b)<<endl;
    cout<<a<<" "<<b<<" "<<c<<" "<<max(max(a,b),c)<<endl;
    return 0;
}


上一篇:顺序表应用6:有序顺序表查询


下一篇:顺序表应用5:有序顺序表归并