面向对象程序设计上机练习一(函数重载)

面向对象程序设计上机练习一(函数重载)

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

利用数组和函数重载求5个数最大值(分别考虑整数、单精度、长整数的情况)。

Input

分别输入5个int型整数、5个float 型实数、5个long型正整数。

Output

分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。

Example Input

11 22 666 44 55
11.11 22.22 33.33 888.88 55.55
1234567 222222 333333 444444 555555

Example Output

666
888.88
1234567

Code realization

#include <iostream>

using namespace std;

int max(int a[])
{
    int m;
    m=a[0];
    for(int i=1;i<5;i++)
    {
        if(m<a[i])
            m=a[i];
    }
    return m;
}

float max(float a[])
{
    float m;
    m=a[0];
    for(int i=1;i<5;i++)
    {
        if(m<a[i])
            m=a[i];
    }
    return m;
}

long max(long a[])
{
    long m;
    m=a[0];
    for(int i=1;i<5;i++)
    {
        if(m<a[i])
            m=a[i];
    }
    return m;
}

int main()
{
    int a[5],m1;
    float b[5],m2;
    long c[5],m3;
    for(int i=0;i<5;i++)
        cin>>a[i];
    for(int i=0;i<5;i++)
        cin>>b[i];
    for(int i=0;i<5;i++)
        cin>>c[i];
    m1=max(a);
    m2=max(b);
    m3=max(c);
    cout<<m1<<endl;
    cout<<m2<<endl;
    cout<<m3<<endl;
    return 0;
}


上一篇:1-4 输出菱形


下一篇:顺序表应用6:有序顺序表查询