A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
代码:
#include<iostream>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
int N,count1=0;
vector<int > keys;
struct node
{
int data;
node* lchild;
node* rchild;
};
node* creat(int L,int R)
{
if(L>R)
return NULL;
int n=R-L+1;
int h=ceil(log(n+1)/log(2));
int bottom=n-pow(2,h-1)+1,BL;
if(bottom>pow(2,h-1)/2)
BL=pow(2,h-1)/2;
else
BL=bottom;
int SL=(pow(2,h-1)-2)/2+BL;
node *root=new node;
root->data=keys[L+SL];
root->lchild=creat(L,L+SL-1);
root->rchild=creat(L+SL+1,R);
return root;
}
void levelorder(node* root)
{
queue<node *> Q;
if(root==NULL)
return;
Q.push(root);
while(!Q.empty())
{
node *p=Q.front();
Q.pop();
count1++;
if(count1==1)
printf("%d",p->data);
else
printf(" %d",p->data);
if(p->lchild!=NULL)
Q.push(p->lchild);
if(p->rchild!=NULL)
Q.push(p->rchild);
}
}
int main()
{
scanf("%d",&N);
int temp;
for(int i=0;i<N;i++)
{
scanf("%d",&temp);
keys.push_back(temp);
}
sort(keys.begin(),keys.end());
node* root=creat(0,N-1);
levelorder(root);
return 0;
}