Seek the Name, Seek the Fame POJ - 2752

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5

题意

找到前缀后缀公共子串,就是next数组的基本性质;

思路

对next数组递归查询


 /*
/ \7    ∠_/
/ │   / /
│ Z _, < /        / `ヽ
│     ヽ         /   〉
Y     `  /      /  /
イ● 、 ●  ⊂⊃    〈 /
()  へ     |      \〈
 > ー 、_  ィ   │     //
	/ へ   / ノ<|    \\
	ヽ_ノ  (_/  │   //
	   7 | /      \    / /
		>―r ̄ ̄`ー―_ _/
*/
#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>

#define N 10000+5
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int n, m;
int nex[400005];
char s1[400005], s2[400005];
int ans[400005];
int len2;
void  getNext()
{
	nex[0] = -1;
	int k = -1;
	int j = 0;
	while (j <n)
	{
		if (k == -1 || s2[j] == s2[k])
		{
			++k;
			++j;
			nex[j] = k;
		}
		else
		{
			k = nex[k];
		}
	}
}

int main()
{
	//int T = 1;

	while (scanf("%s", s2)!=EOF)
	{
		//memset(nex,-1, sizeof(nex));
		//scanf("%s", s2);
		n = strlen(s2);
		   getNext();
		int cnt = 0;
		//int ans[ = n;
		while (n > 0)
		{
			ans[cnt++] = n;
			n = nex[n];

		}
		for (int i = cnt - 1; i >= 0; i--)
		{
			printf("%d ", ans[i]);
		}
		printf("\n");

	}
	return 0;
}


上一篇:后缀数组总结


下一篇:vii