POJ 3250 Bad Hair Day

顺手写个单调队列。。。。

Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

[]   [Go Back]   [Status]  

Description

Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow‘s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow‘s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

Source

[]   [Go Back]   [Status]  

POJ 3250 Bad Hair Day

FAQ | About Virtual Judge | Forum | Discuss | Open Source Project
All Copyright Reserved ?2010-2012 HUST ACM/ICPC TEAM 
Anything about the OJ, please ask in the forum, or contact author:Isun
Server Time: 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>

using namespace std;

long long int n,ct[88888];
struct node
{
    long long int h,id;
}H[88888];

stack<node> q;

int main()
{
    scanf("%I64d",&n);
    for(int i=0;i<n;i++) scanf("%I64d",&H[i].h),H[i].id=i;
    long long int ans=0;
    q.push(H[n-1]);
    for(int i=n-2;i>=0;i--)
    {
        while(!q.empty()&&q.top().h<H[i].h)
        {
            node D=q.top();
            q.pop();
            ct[i]+=(1+ct[D.id]);
        }
        q.push(H[i]);
    }
    for(int i=0;i<n;i++)
    {
        ans+=ct[i];
    }
    printf("%I64d\n",ans);
    return 0;
}


POJ 3250 Bad Hair Day

上一篇:photoshop利用纹理素材及图层样式制作个性的金色纹理字


下一篇:微机接口课程设计报告-模拟汽车控制系统