PAT A1025

1025 PAT Ranking (25 分)

题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
输入:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
输出:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
输入样例:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

输出样例:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

分析

sort函数进行排序,需要自己写一个cmp函数

bool cmp(s a,s b)//s为结构体
{
if(a.score!=b.score) return a.score>b.score;
else return strcmp(a.id,b.id)<0 //相同分数按字典排序,注意这里得strcmp()返回得不是+1,-1,
}

c++代码

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct s
{
	char id[15];//id
	int score;//分数
	int number;//考场编号
	int rank;//场内排名

}stu[30010];
bool cmp(s a, s b)
{
	if (a.score != b.score)  return a.score > b.score;
	else return strcmp(a.id, b.id) < 0;
}
int main()
{
	int num = 0;//总人数
	int n;//考场数
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		int k;//该考场人数
		cin >> k;
		for (int j = 0; j < k; j++)
		{
			cin >> stu[num].id >> stu[num].score;
			stu[num].number = i;
			num++;
		}
		sort(stu+num-k, stu + num,cmp);
		stu[num-k].rank = 1;//num-k代表第一个考场时stu[0]最高分,下一个考场是stu[num-k]为最高分;
		for (int j =num-k+1; j < num; j++)
		{
			if (stu[j].score == stu[j - 1].score)
			{
				stu[j].rank = stu[j - 1].rank;
			}
			else
			{
				stu[j].rank = j + 1-(num-k);
			}
		}
	}
	cout << num << endl;
	sort(stu, stu + num, cmp);
		int r = 1;
	for (int i = 0; i < num; i++)
	{
		if (i > 0 && stu[i].score != stu[i - 1].score)
		{
			r = i + 1;//总排名
		}
		cout << stu[i].id<<" "<<r<<" ";
		cout << stu[i].number << " " << stu[i].rank << endl;;
	}
}

时间紧,思路写的不是很清楚,欢迎留言询问,感谢大家!

上一篇:进制转换


下一篇:【BI学习心得21-常见规划问题2】