Windows App Memory Measurement

Dinner

时间限制:100 ms  |  内存限制:65535 KB
难度:1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示

The tableware only contains: bowl, knife, fork and chopsticks.

解析:最后每行输出最后一个单词不控制空格的话也可ac,nyoj上这点没严格控制

用容器vector写的,可以直接用数组,时间基本一样哈!

#include <iostream>
#include <vector>
#include <string>
using std::endl;
using std::cin;
using std::cout;
using std::string;
using std::vector;
int main()
{
	int n;
	vector<string> vs;
	while(cin >> n)
	{
		for(int i=0;i<n;++i)
		{
			string str;
			cin >> str;
			vs.push_back(str);
		}
		for(int i=0;i<n;++i)
		{
			string temp;
			temp = vs[i];
			if(temp.compare("bowl") ==0 || temp.compare("knife") ==0 || temp.compare("fork") ==0 ||temp.compare("chopsticks") == 0)
			{
				cout << temp;
				//判断是否输出空格
				if(i!=n-1)
				   cout << " ";
			}
		}
		cout << endl;
		vs.clear();
	}
	return 0;
}

Windows App Memory Measurement,布布扣,bubuko.com

Windows App Memory Measurement

上一篇:uva 12002 - Happy Birthday(LIS)


下一篇:android 系统开发 学习方向