Network Saboteur
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 14742 | Accepted: 7265 |
Description
A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.
Output
Output must contain a single integer -- the maximum traffic between the subnetworks.
Sample Input
3 0 50 30 50 0 40 30 40 0
Sample Output
90
题意:把一些点分为两组,求这些点间的距离最大值
刚开始还以为是图论,遂wa
用DFS暴力搜索
将点一个个尝试着放到另一组中,递归,求最大值
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define range 25
int map[range][range];
bool vis[range];
int n,cnt;
void dfs(int d,int sum)
{
int i,j;
vis[d]=true;
for(i=0;i<n;i++)
{
if(vis[i])
sum-=map[d][i];
else
sum+=map[d][i];
}
cnt=cnt>sum?cnt:sum;
for(i=d+1;i<n;i++)
{
dfs(i,sum);
vis[i]=false;
}
}
int main()
{
while(cin>>n)
{
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
cin>>map[i][j];
}
}
memset(vis,false,sizeof(vis));
cnt=0;
dfs(0,0);
cout<<cnt<<endl;
}
return 0;
}