学到栈了..先放一下模板吧!这个使用数组来模拟栈,STL不得不说真心好用啊,hhh!

#include<iostream>
using namespace std;
const int N=10010;
int stk[N],tt;//tt表示栈顶下标
//插入 
stk[++tt]=x;
//删除
tt--;
//判断是否为空
if(tt>0) not empty;
else empty;
//栈顶
stk[tt]; 

模拟栈:

实现一个栈,栈初始为空,支持四种操作:

  1. push x – 向栈顶插入一个数 xx;
  2. pop – 从栈顶弹出一个数;
  3. empty – 判断栈是否为空;
  4. query – 查询栈顶元素。

现在要对栈进行 MM 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 MM,表示操作次数。

接下来 MM 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 empty 和 query 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YES 或 NOquery 操作的查询结果为一个整数,表示栈顶元素的值。

数据范围

1≤M≤1000001≤M≤100000,
1≤x≤1091≤x≤109
所有操作保证合法。

输入样例:

10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty

输出样例:

5
5
YES
4
NO

#include<iostream>
using namespace std;
const int N=100010;
int stk[N],tt;
int main(){
    int n;
    cin>>n;
    while(n--)
    {
        string ch;
        cin>>ch;
        if(ch=="push")
        {
            int x;
            cin>>x;
            stk[++tt]=x;
        }
        else if(ch=="pop") tt--;
        else if(ch=="query") cout<<stk[tt]<<endl;
        else if(ch=="empty") cout<<(tt?"NO":"YES")<<endl;
    }
    return 0;
}

 

上一篇:自制空组件


下一篇:86. 分隔链表