acwing-829. 模拟队列

实现一个队列,队列初始为空,支持四种操作:

  1. push x – 向队尾插入一个数 x;
  2. pop – 从队头弹出一个数;
  3. empty – 判断队列是否为空;
  4. query – 查询队头元素。

现在要对队列进行 M 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。

输入格式

第一行包含整数 M,表示操作次数。

接下来 M 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 emptyquery 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YESNOquery 操作的查询结果为一个整数,表示队头元素的值。

数据范围

1≤M≤100000,
1≤x≤109,
所有操作保证合法。

输入样例:

10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6

输出样例:

NO
6
YES
4

方法一:

#include <bits/stdc++.h>

using namespace std;

int q[100010];
int b, f, m, x;
string op;
int main() {
    f = b = 0;
    cin >> m;
    while (m--) {
        cin >> op;
        if (op == "push") {
            cin >> x;
            q[b++] = x;
        } else if (op == "pop") {
            f++;
        } else if (op == "empty") {
            cout << (b == f ? "YES" : "NO") << endl;
        } else if (op == "query") {
            cout << q[f] << endl;
        }
    }
}
上一篇:NOIP模拟86(多校19)


下一篇:互联网下半场的角逐,玩转轻资产的大数据服务 | 阿里云栖开发者沙龙大数据专场(北京站)