PAT A1128 N Queens Puzzle (20 分)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

PAT A1128 N Queens Puzzle (20 分)

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ ... Q​N​​", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

实现思路:
本题并没有要求给出一个数字去输出所有可能的N皇后答案,而是固定列号,给每列第几行放皇后,来判断是否符合要求。
N-皇后问题指没有两个皇后在同一行同一列和对角线及副对角线上,这题有个技巧就是主对角和副对角是等腰三角形可以用代码中的判断形式去写。

AC代码:

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;

//题设默认所有皇后不为同一列
int main() {
	int n,k,val;
	cin>>n;
	while(n--) {
		scanf("%d",&k);
		bool tag=true;
		vector<int> row(k);
		for(int i=0; i<k; i++) {
			scanf("%d",&row[i]);
			for(int j=0; j<i; j++) {
//皇后在同一列且某条主副对角有两个及以上的皇后时不合法
				if(row[i]==row[j]||abs(row[i]-row[j]==j-i)) {
					tag=false;
					break;
				}
			}
		}
		if(tag) printf("YES");
		else printf("NO");
		cout<<endl;
	}
	return 0;
}
上一篇:HTML语法


下一篇:基于微信小程序的五子棋小程序(含简单人机)