POJ 3259 Wormholes

spfa找负环。。。。

B - Wormholes
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ‘s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires Tseconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>

using namespace std;

const int MaxV=800;
const int MaxE=8000;

typedef struct Edge
{
    int to,next,cost;
}Edge;

Edge edge[MaxE];
int Adj[MaxV],Size;

void Init()
{
    memset(Adj,-1,sizeof(Adj));
    Size=0;
}

void Add_Edge(int u,int v,int c)
{
    edge[Size].to=v;
    edge[Size].next=Adj[u];
    edge[Size].cost=c;
    Adj[u]=Size++;
}

int dist[MaxV],cQ[MaxV];
bool inQ[MaxV];

bool spfa()
{
    memset(dist,63,sizeof(dist));
    memset(cQ,0,sizeof(cQ));
    memset(inQ,false,sizeof(inQ));
    dist[1]=0;
    queue<int> q;
    inQ[1]=true;q.push(1); cQ[1]=1;

    while(!q.empty())
    {
        int u=q.front();q.pop();

        for(int i=Adj[u];~i;i=edge[i].next)
        {
            int v=edge[i].to;
            if(dist[v]>dist[u]+edge[i].cost)
            {
                dist[v]=dist[u]+edge[i].cost;
                if(!inQ[v])
                {
                    inQ[v]=true;
                    cQ[v]++;
                    if(cQ[v]>=MaxV) return true;
                    q.push(v);
                }
            }
        }
        inQ[u]=false;
    }
    return false;
}

int main()
{
    int T;
    scanf("%d",&T);
while(T--)
{
    int a,b,c;
    scanf("%d%d%d",&a,&b,&c);
    Init();
    for(int i=0;i<b;i++)
    {
        int u,v,c;
        scanf("%d%d%d",&u,&v,&c);
        Add_Edge(u,v,c);
        Add_Edge(v,u,c);
    }
    for(int i=0;i<c;i++)
    {
        int u,v,c;
        scanf("%d%d%d",&u,&v,&c);
        Add_Edge(u,v,-c);
    }
    if(spfa()) puts("YES"); else puts("NO");
}
    return 0;
}




POJ 3259 Wormholes

上一篇:JEECG企业微云快速二次开发平台-新版本首页展示


下一篇:利用TCP协议进行ping