1048 Find Coins (25 分)并未AC

1048 Find Coins (25 分)并未AC

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

Analysis

这道题我并没有通过,测试点3答案错误,我检查了代码但是找不到问题,挺疑惑的,决定先放出来。各位大神如果看到错误请教教我,万分感谢。

Code(cpp)

#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int n, m;
    cin >> n >> m;
    int a[n], b[501]={0};
    
    for(int i=0; i<n; i++)
    {
        cin >> a[i];
        b[a[i]]++;
    }
    sort(a, a+n);
    for(int i=0; i<n; i++)
    {
        b[a[i]]--;
        if(b[m-a[i]])
        {
            cout << a[i] << " " << m-a[i];
            return 0;
        }
        b[a[i]]++;
    }
    cout << "No Solution";
}

附上柳神的代码

#include <iostream>
using namespace std;
int a[1001];
int main() {
    int n, m, temp;
    scanf("%d %d", &n, &m);
    for(int i = 0; i < n; i++) {
        scanf("%d", &temp);
        a[temp]++;
    }
    for(int i = 0; i < 1001; i++) {
        if(a[i]) {
            a[i]--;
            if(m > i && a[m-i]) {
                printf("%d %d", i, m - i);
                return 0;
            }
            a[i]++;
        }
    }
    printf("No Solution");
    return 0;
}
上一篇:1048 数字加密 (20 分)


下一篇:tiktokOA 1048. Longest String Chain