任意给定一个字符串,字符串中包含除了空白符、换行符之外的的任意字符。你的任务是统计出现在该字符串中的各字母(即“A—Z”,“a—z”)的个数(区分大小写)。
输入格式:
一个长度不超过100的非空字符串。字符串中不会出现空白符、换行符。
输出格式:
字符串中出现的字母的统计信息,每个字母的统计信息占一行,按照字母的ASCII码的顺序输出。
输入样例:
AAAsdf&^%DF879as
输出样例:
注意单词“time”不论单复数,一律输出复数形式“times”
The character A has presented 3 times.
The character D has presented 1 times.
The character F has presented 1 times.
The character a has presented 1 times.
The character d has presented 1 times.
The character f has presented 1 times.
The character s has presented 2 times.
代码如下:
#include<stdio.h>
int main()
{
int i;
char ar[100] = { 0 };
scanf("%s", ar);
//注意这两个数组的引入和使用
int a[26] = { 0 };
int A[26] = { 0 };
for (i = 0; ar[i] != '\0'; i++)
{
if (ar[i] >= 'a' && ar[i] <= 'z')
a[ar[i] - 'a']++;
else if (ar[i] >= 'A' && ar[i] <= 'Z')
A[ar[i] - 'A']++;
}
for (i = 0; i < 26; i++)
if (A[i] != 0)
printf("The character %c has presented %d times.\n", i + 'A', A[i]);
for (i = 0; i < 26; i++)
if (a[i] != 0)
printf("The character %c has presented %d times.\n", i + 'a', a[i]);
return 0;
}
这里大家要注意我统计字母个数的方法。
两个数组的引入!!