POJ3041
Asteroids
Time Limit: 1000MS | Memory Limit: 65536K | |
---|---|---|
Total Submissions: 29541 | Accepted: 15802 |
Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.
* Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:X.X.X..X.
OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
Source
- 匈牙利算法
- 这个建模的方式可真是没想到
- 得到一个结论, 二分图的最小覆盖的顶点为二分图最大匹配的顶点
#pragma warning(disable:4996)
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 505;//顶点的个数
const int maxm = 10005;
int n, m;
int g[maxn][maxn];
int linker[maxn];
bool used[maxn];
bool dfs(int u) {
for (int v = 0; v < n; v++) {
if (g[u][v] && !used[v]) {
used[v] = true;
if (linker[v] == -1 || dfs(linker[v])) {
linker[v] = u;
return true;
}
}
}
return false;
}
int hungary() {
int res = 0;
memset(linker, 0xff, sizeof(linker));
for (int u = 0; u < n; u++) {
memset(used, false, sizeof(used));
if (dfs(u)) {
res++;
}
}
return res;
}
int main() {
cin >> n >> m;
int u, v;
for (int i = 0; i < m; i++) {
scanf("%d%d", &u, &v);
g[u - 1][v - 1] = 1;
}
/*for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
cout << g[i][j] << " ";
}
cout << "\n";
}*/
cout << hungary() << "\n";
return 0;
}
shen253135371
发布了21 篇原创文章 · 获赞 8 · 访问量 2659
私信
关注