ACM----E - Milking Time

黑色的飞鸟掠过天空,我站在城中,看时间燃成灰烬,哗哗作响......

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

农民挤奶,有时间段限制,还有休息时间。。。贪心,然后动规

#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <vector>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
#define inf 1000000007
typedef long long ll;
using namespace std;
int dp[1010];//第i次挤奶时最大产奶量
struct node{
    int ks;
    int js;
    int xl;
}p[1010];
int cmp(node x,node y){
    if(x.ks==y.ks)
        return x.js<y.js;
    return x.ks<y.ks;
}
int main(){
    int N,M,R,i,j,jg=-1;
    scanf("%d%d%d",&N,&M,&R);
    for(i=0;i<M;i++)
        scanf("%d%d%d",&p[i].ks,&p[i].js,&p[i].xl);
    sort(p,p+M,cmp);
    for(i=0;i<M;i++){
        dp[i]=p[i].xl;
        for(j=0;j<i;j++){
        if(p[j].js+R<=p[i].ks)
            dp[i]=max(dp[i],dp[j]+p[i].xl);
        }
        jg=max(jg,dp[i]);
    }
    printf("%d\n",jg);
    return 0;
}

 

上一篇:Asteroids【最小点覆盖】


下一篇:20-1-23-匈牙利算法-POJ3041