Given any string of N (≥5) characters, you are asked to form the characters into the shape of U
. For example, helloworld
can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U
to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!
结尾无空行
Sample Output:
h !
e d
l l
lowor
结尾无空行
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
string a;
cin>>a;
int len=a.length()+2;
int b=len/3; //竖着的长度
int i,j;
j=len%3+b; //最底下一层的长度
int kong=j-2;
for(i=0;i<b-1;i++) //输出前b-1行的内容
{
cout<<a[i];
for(int o=0;o<kong;o++){
cout<<" ";
}
cout<<a[len-3-i]<<endl;
}
//输出最后一行
for( i=b-1;i<=b+kong;i++)
{
cout<<a[i];
}
}