寒假私训 —— 并查集 E - How Many Tables

E - How Many Tables

题目要求

 Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

解题思路

该题和第一题A题思路差不多,检查连通性的,看有几个根节点,以判断有几个树,代码如下:

代码

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 1000100
using namespace std;

 int f[maxn];

 int find(int x){
     if(x==f[x]){
         return x;
     }
     f[x]=find(f[x]);
     return f[x];
 }

 int main(){
     int t,i;
     scanf("%d", &t);
     for(i=1;i<=t;i++){
         int n,m;
         scanf("%d%d",&n,&m);
         for(int i=1; i<=n; i++){
             f[i] = i;
         }
         int sum=0;
         while(m--){
             int x, y;
             scanf("%d%d",&x,&y);
             int f1=find(x);
             int f2=find(y);
             if(f1!=f2)
                 f[f2]=f1;
         }

         for(int j=1;j<=n;j++){
               int a=find(j);
               if(a==j)
                              sum++;
         }
          printf("%d\n",sum);
     }
     return 0;
 }
寒假私训 —— 并查集  E - How Many Tables寒假私训 —— 并查集  E - How Many Tables atnana 发布了29 篇原创文章 · 获赞 0 · 访问量 719 私信 关注
上一篇:从天津百货大楼 5 病例“迷局”见新冠病毒传播路径


下一篇:HDU - 1213 How Many Tables