HDOJ-1003 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

最大子序和问题。不过是要多存序列开头和结尾的位置。一次AC看代码吧。

//46MS  2068K
#include<iostream>
#include<cstdio>
using namespace std;
#define maxn 100005
int main(){
    int T,j=1;
    scanf("%d",&T);
    while(T--){
        int N,S[maxn];
        scanf("%d",&N);
        for(int i=1;i<=N;i++){
            scanf("%d",&S[i]);
        }
        int sum=0,max=-1005,first=0,last=0,temp=1;
        for(int i=1;i<=N;i++){
            sum+=S[i];
            if(sum>max){
                max=sum;
                first=temp;
                last=i;
            }
            if(sum<0){
                sum=0;
                temp=i+1;
            }
        }
        printf("Case %d:\n%d %d %d\n",j++,max,first,last);
        if(T!=0)
            printf("\n");
    }
    return 0;
}
上一篇:1001.Is Derek lying?


下一篇:C-POJ-1426 Find The Multiple