HDOJ-1001 Sum Problem

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

水题

#include<stdio.h>
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        int sum=0,i;
        for(i=1;i<=n;i++){
            sum+=i;
        }
        printf("%d\n\n",sum);
    }
    return 0;
}
上一篇:B-POJ-3278 Catch That Cow


下一篇:HDOJ-2010 水仙花数