1001.Add More Zero

Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
1
64

Sample Output
Case #1: 0
Case #2: 19

题解如下,水题没啥说的

1001.Add More Zero

//202MS 1508K
#include <cstdio>  
#include <cstring>  
#include <algorithm> 
#include <cmath>
using namespace std;
int main()
{
    int cas=1;
    int n;
    while(scanf("%d",&n)!=EOF){
        printf("Case #%d: ",cas);   cas++;
        int w=n*log(2)/log(10);
        printf("%d\n",w);
    }
    return 0;
} 
上一篇:《HTML5 canvas开发详解(第2版)》——2.8 用颜色和渐变填充对象


下一篇:B-POJ-3278 Catch That Cow