Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
**Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.**
Sample Input
1
100
Sample Output
1
5050
#include<stdio.h>
#include<stdlib.h>
int main()
{
int n,sum;
while(scanf("%d",&n)!=EOF)//多次输入
{
sum=0;//放入循环体内,保证每次sum都被清0
while(n)//当n!=0时,执行循环
{
sum+=n;//累加
n=n-1;
}
printf("%d\n\n",sum);//输出结果
}
return 0;
}