Find them, Catch them-POJ - 1703-并查集

Find them, Catch them

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题意:有两个帮派,有n个人和m条信息,每条信息前如果是D则说明这两个人是属于不同的帮派,如果是A则判断这两个人的关系
解题思路:用并查集保存属于一个帮派的人,处理的思路是借鉴大佬的博客( ̄︶ ̄)↗

AC代码:
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<string>
#include<sstream>
#include<cmath>
#include<set>
#include<map>
#define maxn 1000000000
using namespace std;
typedef long long ll;
int p[100005],opposite[100005];
int root(int a)
{
    return p[a]==a ? a:p[a]=root(p[a]);
}
void unite(int a,int b)
{
    p[root(a)]=root(b);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        memset(opposite,0,sizeof(opposite)); //用该数组保存与下标表示的人 对立的人 的编号
        for(int i=1; i<=n; i++)
            p[i]=i;
        for(int i=0; i<m; i++)
        {
            getchar();
            char c;
            int x,y;
            scanf("%c%d%d",&c,&x,&y);
            if(c=='A')
            {
                if(root(x)==root(y)) //根相同说明属于同一个帮派
                    printf("In the same gang.\n");
                else if(root(x)==root(opposite[y]))//注意这里的处理,因为可能有多个集合,他们之间根不同且不能判断他
                    printf("In different gangs.\n");们的关系,但是可以通过如果x与y对立的人属于同一个帮派,那么他们一定
                else printf("Not sure yet.\n"); 属于不同的帮派来判断。
            }
            else
            {
                if(opposite[x]) unite(opposite[x],y); //x与y不属于同一个帮派,那么y一定与x对立的人是同一个帮派
                if(opposite[y]) unite(opposite[y],x);
                opposite[x]=y; //如果有与x对立的人,那么在上方就已经与y合并了,所以不用担心被覆盖。
                opposite[y]=x;
            }
        }
    }
    return 0;
}
上一篇:PAT 1034 Head of a Gang (30 分)————Python


下一篇:1034 Head of a Gang (30 point(s)) - C语言 PAT 甲级