Catch That Cow
Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it? Input Line 1: Two space-separated integers: N and KOutput Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.Sample Input Sample Output Hint The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.Source USACO 2007 Open Silver |
[Submit] [Go Back] [Status] [Discuss]
#include<string.h>
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
const int N=100050;
int n,m;
int d[N];
void bfs()
{
queue<int>q;
q.push(n);
d[n]=0;
while(q.size())
{
int t=q.front();
q.pop();
int dx[3]={1,-1,t};
for(int i=0;i<3;i++)
{
int nx=dx[i]+t;
if(nx<0||nx>=N)
continue;
if(d[nx]!=-1)
continue;
d[nx]=d[t]+1;
q.push(nx);
if(nx==m)return;
}
}
}
int main()
{
cin>>n>>m;
memset(d,-1,sizeof(d));
bfs();
cout<<d[m]<<endl;
return 0;
}