1042 字符统计 (20 分)

1042 字符统计 (20 分)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7
 
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.StringTokenizer;

/**
 * @author hang
 * @create 2022/2/6 13:28
 */
public class Test1042 {

    static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
    static StringTokenizer tokenizer = new StringTokenizer("");

    public static void main(String[] args) throws IOException {
         String a = reader.readLine().toLowerCase();
         int[] arr = new int[10000];
         for (int i = 0; i < a.length(); i ++) {
             arr[a.charAt(i)] ++;
         }
         int min = 0;
         int j = 0;
        for (int i = 97; i < 128; i ++) {
            if (arr[i] > min) {
                j = i;
                min = arr[i];
            }
        }
        System.out.println((char)j + " " + min);
    }

    static String next() throws IOException {
        while (!tokenizer.hasMoreTokens()) {
            tokenizer = new StringTokenizer(reader.readLine());
        }
        return tokenizer.nextToken();
    }

    static int nextInt() throws IOException {
        return Integer.parseInt(next());
    }

    static double nextDoule() throws IOException {
        return Double.parseDouble(next());
    }

    static long nextLong() throws IOException {
        return Long.parseLong(next());
    }
}

总结

  • 先将大写字母转变成小写字母
  • 再用数组存储字母出现次数,然后遍历
上一篇:19.异常处理(新年快乐啊)


下一篇:包机制和JavaDoc