SWUST OJ 1102: 顺序表上数据的划分问题的实现

题目描述

建立一个顺序表L,然后以第一个为分界,将所有小于等于它的元素移到该元素的前面,将所有大于它的元素移到该元素的后面。

输入

顺序表长度n;
顺序表中的数据元素。

输出

移动后的数据元素。

样例输入

10
32 5 22 43 23 56 54 57 11 25

样例输出

25 11 23 22 5 32 43 56 54 57

参考程序

#include<stdio.h>
#include<stdlib.h>

#define Maxsize 50

int j = 0;
int b[Maxsize];

typedef struct sqlist
{
	int data[Maxsize];
	int rear;
}Sqlist;

void Init(Sqlist *&L)
{
	L = (Sqlist *) malloc (sizeof(Sqlist));
	L->rear = -1;
}

bool Push(Sqlist *&L, int e)
{
	if(L->rear == Maxsize-1)	return false;
	L->rear++;
	L->data[L->rear] = e;
	return true;
}

bool Pop(Sqlist *&L, int &e)
{
	if(L->rear == -1)	return false;
	e = L->data[L->rear];
	L->rear--;
	return true;
}

void Creat(Sqlist *&L, Sqlist *&S, int n)
{
	int a[Maxsize];
	for(int i = 0; i<n; i++)
		scanf("%d", &a[i]);
	Push(S, a[0]);
	for(int i=1; i<n; i++)
	{
		if(a[0] > a[i])
			Push(L, a[i]);
		else	Push(S, a[i]);
	}
}

int main()
{
	int n, e, *b[Maxsize];
	int a[Maxsize];
	Sqlist *L, *S;
	Init(L);
	Init(S);
	scanf("%d", &n);
	Creat(L, S, n);
	while(L->rear != -1)
	{
		Pop(L, e);
		printf("%d ", e);
	}
	for(int i=0; i<=S->rear; i++)
		printf("%d ", S->data[i]);
	return 0;
}

注意

该程序仅供学习参考!

上一篇:数据结构之队列


下一篇:1.创建数据库