Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 12856 | Accepted: 6240 |
Description
A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
Input
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0
Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)
Source
题目链接:POJ 1573
简单BFS,过不了的是试一下这组样例……
Try this test case:
2 2 1
SW
EN The right answer should be:
0 step(s) before a loop of 4 step(s)
由于刚开始的步数为0,加了一个vis数组,用一个数组记录每一次到的地方的步数即可,若访问过就说明有回路,若可以走出界则说明有出口……
代码:
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<bitset>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=15;
char pos[N][N];
int his_step[N][N];
int vis[N][N];
struct info
{
int x;
int y;
int step;
info operator+(info b)
{
b.x+=x;
b.y+=y;
b.step+=step;
return b;
}
};
info S,direct[4]={{0,1,1},{0,-1,1},{1,0,1},{-1,0,1}};
int n,m,c;
void init()
{
CLR(pos,0);
CLR(his_step,0);
CLR(vis,0);
}
int main(void)
{
int i,j,k,ans1,ans2;
while (~scanf("%d%d%d",&n,&m,&c)&&(n||m||c))
{
init();
ans1=-1;
ans2=-1;
for (i=0; i<n; ++i)
scanf("%s",pos[i]);
S.x=0;
S.y=c-1;
S.step=0;
queue<info>Q;
Q.push(S);
while (!Q.empty())
{
info now=Q.front();
Q.pop();
if(vis[now.x][now.y])
{
ans1=his_step[now.x][now.y];
ans2=now.step-his_step[now.x][now.y];
break;
}
else
{
his_step[now.x][now.y]=now.step;
vis[now.x][now.y]=1;
}
info v;
switch(pos[now.x][now.y])
{
case 'N':v=now+direct[3];break;
case 'S':v=now+direct[2];break;
case 'W':v=now+direct[1];break;
case 'E':v=now+direct[0];break;
}
if(v.x<0||v.x>=n||v.y<0||v.y>=m)
{
ans1=v.step;
break;
}
Q.push(v);
}
if(ans2==-1)
printf("%d step(s) to exit\n",ans1);
else
printf("%d step(s) before a loop of %d step(s)\n",ans1,ans2);
}
return 0;
}