题目
求最长上升子序列
输入
第一行包含一个整数n。
第二行包含n个整数,表示整数序列。
输出格式
输出最长子序列长度值。
数据范围
1≤n≤1001,
输入样例:
8
2 11 5 77 4 10 9 8
输出样例:
3
我用c(混杂)写的,但建议单用c++写。
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
int n,a[1001],i,j,longth[1001];
scanf("%d",&n);//The length of the input。
for(i=0;i<n;i++){
scanf("%d",&a[i]);//Put in these numbers.
}
for(i=0;i<=n;i++){
longth[i]=1;//The unprecedented length will be one.
}
for(i=1;i<n;i++){
for(j=0;j<n;j++){
if(a[i]>a[j]){
longth[i]=max(longth[i],longth[j]+1);//Find the largest and assign it to longth[i].
}
}
}
printf("%d",*max_element(longth,longth+n));//Output the maximum length.
return 0;
}