hdu 1251 统计难题(字典树)

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)

Total Submission(s): 22291    Accepted Submission(s): 9424

Problem Description
Ignatius近期遇到一个难题,老师交给他非常多单词(仅仅有小写字母组成,不会有反复的单词出现),如今老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每一个提问都是一个字符串.



注意:本题仅仅有一组測试数据,处理到文件结束.
 
Output
对于每一个提问,给出以该字符串为前缀的单词的数量.
 
Sample Input
banana
band
bee
absolute
acm ba
b
band
abc
 
Sample Output
2
3
1
0
 
Author
Ignatius.L
 
Recommend
 

题解:建一颗字典树,然后查询出现的次数即可了。

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
#include<cstring>
#define N 10010 using namespace std; int n;
char s[N]; typedef struct tire {
int num;
struct tire *net[26];
}*Tire; void Init(Tire &p) {
p=(Tire)malloc(sizeof(tire));
p->num=0;
for(int i=0; i<26; i++) {
p->net[i]=NULL;
}
} void CreatTire(Tire &p,char s[]) {
int i=0;
Tire q=p;
while(s[i]) {
int nx=s[i]-'a';
if(q->net[nx]==NULL) {
Init(q->net[nx]);
q->net[nx]->num=1;
} else {
q->net[nx]->num++;
}
q=q->net[nx];
i++;
}
} int Serch(Tire p,char s[]) {
int i=0;
Tire q=p;
while(s[i]) {
int nx=s[i]-'a';
if(q->net[nx]==NULL)return 0;
q=q->net[nx];
i++;
}
return q->num;
} int main() {
//freopen("test.in","r",stdin);
Tire p;
Init(p);
while(gets(s)!=NULL&&s[0]!='\0') {
CreatTire(p,s);
}
while(~scanf("%s",s)) {
printf("%d\n",Serch(p,s));
}
return 0;
}
上一篇:基于Visual C++2013拆解世界五百强面试题--题4-double转换成字符串


下一篇:Vue知识点超快速学习