HDU 2.1.7 (求定积分公式)

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1637 Accepted Submission(s): 1298
 
Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note:
The point P1 in the picture is the vertex of the parabola.

HDU 2.1.7 (求定积分公式)

 
Input
The input contains several test cases. The first line
of the input is a single integer T which is the number of test cases. T test
cases follow.
Each test case contains three intersectant points which shows
in the picture, they are given in the order of P1, P2, P3. Each point is
described by two floating-point numbers X and
Y(0.0<=X,Y<=1000.0).
 
Output
For each test case, you should output the area of the
land, the result should be rounded to 2 decimal places.
 
Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
 
Sample Output
33.33
40.69
Hint

For float may be not accurate enough, please use double instead of float.

 
Author
Ignatius.L

求定积分公式

#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
using namespace std;
double a,b,c;
double f(double x)
{
return 1.0/*a*x*x*x+0.5*b*x*x+c*x;
}
int main()
{
double x1,y1,x2,y2,x3,y3;
int n;
cin>>n;
while(n--)
{
cin>>x1>>y1>>x2>>y2>>x3>>y3;
a=(y2-y1)/((x2-x1)*(x2-x1)); //顶点式求a
b=-*a*x1; //对称轴求b
c=y1-a*x1*x1-b*x1; //一般式求c
printf("%.2lf\n",f(x3)-f(x2)-(y3+y2)*(x3-x2)/); //定积分
}
return ;
}
上一篇:[leetcode]41. First Missing Positive第一个未出现的正数


下一篇:【排序算法】快速排序算法 Java实现