Poor God Water【矩阵快速幂】

Poor God Water
时间限制: 1 Sec 内存限制: 128 MB
提交: 102 解决: 50
[提交] [状态] [命题人:admin]
题目描述
God Water likes to eat meat, fish and chocolate very much, but unfortunately, the doctor tells him that some sequence of eating will make them poisonous.
Every hour, God Water will eat one kind of food among meat, fish and chocolate. If there are 3 continuous hours when he eats only one kind of food, he will be unhappy. Besides, if there are 3 continuous hours when he eats all kinds of those, with chocolate at the middle hour, it will be dangerous. Moreover, if there are 3 continuous hours when he eats meat or fish at the middle hour, with chocolate at other two hours, it will also be dangerous.
Now, you are the doctor. Can you find out how many different kinds of diet that can make God Water happy and safe during N hours? Two kinds of diet are considered the same if they share the same kind of food at the same hour. The answer may be very large, so you only need to give out the answer module 1000000007.

输入
The fist line puts an integer T that shows the number of test cases. (T≤1000)
Each of the next T lines contains an integer N that shows the number of hours. (1≤N≤10^10)

输出
For each test case, output a single line containing the answer.

样例输入
复制样例数据
3
3
4
15
样例输出
20
46
435170

题目大意:
假设鱼为aaa,肉为bbb,巧克力为ccc,先输入一个数字TTT,表示共有TTT组测试数据,下面TTT行每行输入一个整数nnn,代表有nnn个时刻,每个时刻可以吃一种食物,但不能连续三个小时吃同一种食物,即aaaaaaaaa,bbbbbbbbb,ccccccccc不合法,当在三个小时内三种食物都吃的话,巧克力不能放中间,即acbacbacb,bcabcabca不合法,还有就是caccaccac,bcbbcbbcb,问共有多少种吃法。

解题思路:
n=1n=1n=1时,有f[1]=3f[1]=3f[1]=3种吃法,即a,b,ca,b,ca,b,c
n=2n=2n=2时,有f[2]=9f[2]=9f[2]=9种吃法,并假设
1aa     2ba     3ca1、aa\ \ \ \ \ 2、ba\ \ \ \ \ 3、ca1、aa     2、ba     3、ca
4ab     5bb     6cb4、ab\ \ \ \ \ 5、bb\ \ \ \ \ 6、cb4、ab     5、bb     6、cb
7ac     8bc     9cc7、ac\ \ \ \ \ 8、bc\ \ \ \ \ 9、cc7、ac     8、bc     9、cc
n=3n=3n=3时,有f[3]=20f[3]=20f[3]=20种吃法
1aa{bc     2ba{abc     3ca{ab1、aa\begin{cases}b \\c \end{cases}\ \ \ \ \ 2、ba\begin{cases}a\\b \\c \end{cases}\ \ \ \ \ 3、ca\begin{cases}a \\b \end{cases}1、aa{bc​     2、ba⎩⎪⎨⎪⎧​abc​     3、ca{ab​
4ab{abc     5bb{ac     6cb{ab4、ab\begin{cases}a\\b \\c \end{cases}\ \ \ \ \ 5、bb\begin{cases}a \\c \end{cases}\ \ \ \ \ 6、cb\begin{cases}a \\b \end{cases}4、ab⎩⎪⎨⎪⎧​abc​     5、bb{ac​     6、cb{ab​
7ac{ac     8bc{bc     9cc{ab7、ac\begin{cases}a \\c \end{cases}\ \ \ \ \ 8、bc\begin{cases}b \\c \end{cases}\ \ \ \ \ 9、cc\begin{cases}a \\b \end{cases}7、ac{ac​     8、bc{bc​     9、cc{ab​
n>=3n>=3n>=3时
其情况111的个数有:f[n1].2+f[n1].3f[n-1].2+f[n-1].3f[n−1].2+f[n−1].3
其情况222的个数有:f[n1].4+f[n1].5+f[n1].6f[n-1].4+f[n-1].5+f[n-1].6f[n−1].4+f[n−1].5+f[n−1].6
其情况333的个数有:f[n1].7+f[n1].9f[n-1].7+f[n-1].9f[n−1].7+f[n−1].9
其情况444的个数有:f[n1].1+f[n1].2+f[n1].3f[n-1].1+f[n-1].2+f[n-1].3f[n−1].1+f[n−1].2+f[n−1].3
其情况555的个数有:f[n1].4+f[n1].6f[n-1].4+f[n-1].6f[n−1].4+f[n−1].6
其情况666的个数有:f[n1].8+f[n1].9f[n-1].8+f[n-1].9f[n−1].8+f[n−1].9
其情况777的个数有:f[n1].1+f[n1].2f[n-1].1+f[n-1].2f[n−1].1+f[n−1].2
其情况888的个数有:f[n1].4+f[n1].5f[n-1].4+f[n-1].5f[n−1].4+f[n−1].5
其情况999的个数有:f[n1].7+f[n1].8f[n-1].7+f[n-1].8f[n−1].7+f[n−1].8
所以可得:
f[n].1f[n].2f[n].3f[n].4f[n].5f[n].6f[n].7f[n].8f[n].9000000000000000000000000000000000000000000000000000000000000000000000000=111111111000000000000000000000000000000000000000000000000000000000000000000000000×000100100100100100100100000010010010010000010010010000001000001000001001001001000n2\begin{vmatrix} f[n].1 & f[n].2& f[n].3 & f[n].4 & f[n].5 & f[n].6 & f[n].7 & f[n].8 & f[n].9 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ \end{vmatrix}=\begin{vmatrix} 1 & 1 & 1 & 1 & 1 & 1 & 1 & 1 & 1 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ \end{vmatrix}\times\begin{vmatrix} 0 & 0 & 0 & 1 & 0 & 0 & 1 & 0 & 0 \\ 1 & 0 & 0 & 1 & 0 & 0 & 1 & 0 & 0 \\ 1 & 0 & 0 & 1 & 0 & 0 & 0 & 0 & 0 \\ 0 & 1 & 0 & 0 & 1 & 0 & 0 & 1 & 0 \\ 0 & 1 & 0 & 0 & 0 & 0 & 0 & 1 & 0 \\ 0 & 1 & 0 & 0 & 1 & 0 & 0 & 0 & 0 \\ 0 & 0 & 1 & 0 & 0 & 0 & 0 & 0 & 1 \\ 0 & 0 & 0 & 0 & 0 & 1 & 0 & 0 & 1 \\ 0 & 0 & 1 & 0 & 0 & 1 & 0 & 0 & 0 \\ \end{vmatrix}^{n-2}∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣​f[n].100000000​f[n].200000000​f[n].300000000​f[n].400000000​f[n].500000000​f[n].600000000​f[n].700000000​f[n].800000000​f[n].900000000​∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣​=∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣​100000000​100000000​100000000​100000000​100000000​100000000​100000000​100000000​100000000​∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣​×∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣​011000000​000111000​000000101​111000000​000101000​000000011​110000000​000110000​000000110​∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣∣​n−2
因此直接用矩阵快速幂计算即可

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
struct node
{
	ll arr[9][9];
	node() {
		ms(arr);
	}
};
node mul(node a,node b) {
	node c;
	for(int i=0;i<9;i++) {
		for(int j=0;j<9;j++) {
			for(int k=0;k<9;k++) {
				c.arr[i][j]=(c.arr[i][j]+(a.arr[i][k]*b.arr[k][j])%mod+mod)%mod;
			}
		}
	}
	return c;
}
ll quickpow(ll n) {
	node base;
	base.arr[1][0]=1;base.arr[2][0]=1;
	base.arr[3][1]=1;base.arr[4][1]=1;base.arr[5][1]=1;
	base.arr[6][2]=1;base.arr[8][2]=1;
	base.arr[0][3]=1;base.arr[1][3]=1;base.arr[2][3]=1;
	base.arr[3][4]=1;base.arr[5][4]=1;
	base.arr[7][5]=1;base.arr[8][5]=1;
	base.arr[0][6]=1;base.arr[1][6]=1;
	base.arr[3][7]=1;base.arr[4][7]=1;
	base.arr[6][8]=1;base.arr[7][8]=1;
	node a;
	a.arr[0][0]=1;a.arr[0][1]=1;a.arr[0][2]=1;a.arr[0][3]=1;a.arr[0][4]=1;a.arr[0][5]=1;a.arr[0][6]=1;a.arr[0][7]=1;a.arr[0][8]=1;
	while(n) {
		if(n&1) a=mul(a,base);
		base=mul(base,base);
		n>>=1;
	}
	ll ans=0;
	for(int i=0;i<9;i++) {
		ans=(ans+a.arr[0][i])%mod;
	}
	return ans;
}
int main() 
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt", "r", stdin);
    #endif
    //freopen("out.txt", "w", stdout);
    //ios::sync_with_stdio(0),cin.tie(0);
    int T;
    scanf("%d",&T);
    while(T--) {
    	ll n;
    	scanf("%lld",&n);
    	if(n==1) printf("3\n");
    	else printf("%lld\n",quickpow(n-2));
    }
    return 0;
}
上一篇:无线页面加速解决方案-AMP


下一篇:Visual Studio 2005项目及项(文件)模板丢失的解决办法及补充