This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2 2 2 1.5 1 0.5
结尾无空行
Sample Output:
3 2 1.5 1 2.9 0 3.2
结尾无空行
思路:
不能说很简单,只能说完全不要动脑子。
#include<bits/stdc++.h>
using namespace std;
double a[1001][3],b[1001];
int main()
{
int k,count=0;
for(int i=1;i<=2;i++){
cin>>k;
for(int j=1;j<=k;j++){
int m;
cin>>m;
cin>>a[m][i];
}
}
for(int i=0;i<=1000;i++){
b[i]=a[i][1]+a[i][2];
if(b[i]!=0) count++;
}
printf("%d",count);
for(int i=1000;i>=0;i--){
if(b[i]!=0) printf(" %d %.1lf",i,b[i]);
}
}
搞定!!