1009 Product of Polynomials (25 分)
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
#include <iostream>
#include <cstdio>
#include <set>
#include <string>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <map>
using namespace std;
double a[1000005];
struct node{
int n;
double x;
};
int main(){
int k1;
cin>>k1;
node b[k1];
for(int i=0;i<k1;i++){
cin>>b[i].n>>b[i].x;
}
int k2;
cin>>k2;
node c[k2];
for(int i=0;i<k2;i++){
cin>>c[i].n>>c[i].x;
}
for(int i=0;i<k1;i++){
for(int j=0;j<k2;j++){
int temp = b[i].n + c[j].n;
double res = b[i].x * c[j].x;
a[temp] += res;
}
}
int cnt = 0;
for(int i=1000004;i>=0;i--){
if(a[i]!=0.0){
cnt++;
}
}
cout<<cnt;
for(int i=1000004;i>=0;i--){
if(a[i]!=0.0){
printf(" %d %.1lf",i,a[i]);
}
}
cout<<endl;
return 0;
}